Ghost 搬家记录——这次是 Ubuntu

最近从Linode跳到了RamNode,新的服务器上安装了最新的Ubuntu 16.04,在给Ghost搬家的过程中遇到了很多问题,再来记录一下。 关于node.js Ghost现在已经支持node 4 LTS系列,而node.js的官网也提供有4的apt repo,所以直接按照提示运行命令就可以搞定。 关于systemd 我一开始将前文中贴出的systemd示例直接复制到了新服务器上,但是无论如何也无法启动Ghost。首先,systemd说PrivateNetworks这个属性未知;其次,在原先的示例里,npm的路径是/usr/local/bin/ »

从MySQL服务日志里的一个警告说起

随着越来越多的Linux发行版开始使用systemd,不论是发行版软件源还是MySQL官方源,其中的MySQL软件包都开始支持systemd(提供systemd的service定义)。但是由于systemd带来的巨大改变,以前所使用的很多配置方式都有可能失效,而要想达到同样的效果,需要采取新的手段。 [Warning] Changed limits: max_open_files: 5000 (requested 5106) ... 这段警告信息是在最新的CentOS 7上面,安装MySQL 5.7.9并应用了旧的my.cnf之后出现的。可以看到,MySQL服务在启动的时候, »